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Preparing for the installation

Overview

Related resources
Planning your installation
System requirements
Setting up a Microsoft Windows service account and mailbox

Overview

This document covers basic BlackBerry® Enterprise Server installation and administration procedures. It assumes
that you are installing the BlackBerry Enterprise Server components on one dedicated computer.

To install the BlackBerry Enterprise Server and associate a user account with a BlackBerry device, complete the
following tasks:

plan your installation

verify system requirements

set up and assign permissions to a Microsoft® Windows® service account and mailbox

install the BlackBerry Enterprise Server software

set up a BlackBerry device on the BlackBerry Enterprise Server

Related resources

Guide

Information

BlackBerry Enterprise Server Version 4.1 Feature and Technical Overview <

BlackBerry Enterprise Server Version 4.1 Installation Guide .

BlackBerry Enterprise Server Version 4.1 System Administration Guide

BlackBerry Enterprise Server architecture and components
advanced installation options (for example, installation
requirements for instant messaging and the BlackBerry MDS
Services)

setup types and installing the BlackBerry Enterprise Server
components on multiple computers

removing the BlackBerry Enterprise Server from your
computer

advanced BlackBerry setup and administration tasks
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Planning your installation

You can install the BlackBerry Enterprise Server Express or the BlackBerry Enterprise Server - Small Business
Edition on the same computer as your messaging server if you plan to implement 15 or fewer BlackBerry devices in
your organization. If you plan to upgrade your installation to a full BlackBerry Enterprise Server, and support more
than 15 BlackBerry devices, install the BlackBerry Enterprise Server Express or BlackBerry Enterprise Server -
Small Business Edition on a computer separate from the messaging server computer.

System requirements

Your computer should meet the following minimum hardware and software requirements:

Operating system

Requirement

One of the following is installed: O
«  Microsoft Windows 2000 (Server or Advanced editions) with Service Pack (SP) 4

e Microsoft Windows Server® 2003 (Standard, Enterprise or Small Business Server)

Microsoft Data Access Component (MDAC) Version 2.8 SP1 or later is installed. O
Visit http://support.microsoft.com/kb/301202 for more information about verifying your MDAC version.

Hardware
Requirement
Intel® Pentium® 1l processor (800 MHz or greater); Intel Pentium IV processor (2 GHz or greater) is recommended. O
minimum 1.5 or more gigabytes of RAM available O

Messaging server

Requirement

One of the following messaging servers is installed: O
« Microsoft Exchange Version 5.5 native environment

* Microsoft Exchange 2000 native environment

* Microsoft Exchange 2003 native environment
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Requirement
One of the following Microsoft Exchange administration tools is installed on the computer on which you plan to install the O
BlackBerry Enterprise Server:

* Microsoft Exchange Version 5.5 Administrator

* Microsoft Exchange 2000 System Manager

»  Microsoft Exchange 2003 System Manager

Notes:

« Do not install Microsoft Outlook® on the same computer as the Microsoft Exchange administration tool.

* Your Microsoft Exchange administration tool must be the same service pack as your version of Microsoft Exchange. See
“Determine if a Microsoft Exchange System Manager upgrade is required” on page 17 for more information.

Network

Requirement
The corporate firewall or proxy permits the BlackBerry Enterprise Server to initiate and maintain an outbound connection to the [
BlackBerry Infrastructure on TCP port 3101.

The proxy server is transparent if you are using a proxying firewall. O

Database

Requirement
If you have a Microsoft SQL Server 2000 Desktop Engine (MSDE 2000) version that is earlier than MSDE 2000 Release Ainstalled [
on your computer, remove it before starting the BlackBerry Enterprise Server installation

Setting up a Microsoft Windows service account and mailbox

To install the BlackBerry Enterprise Server, and perform administration and upgrade tasks after the installation,
you must log in to your computer using a Microsoft Windows service account with the appropriate permissions.
Before installing the BlackBerry Enterprise Server, you must create and set up this service account and mailbox.

Create a Microsoft Windows service account and mailbox
1. Log in to your computer as an administrator with permission to set up a service account.
2. On the taskbar, click Start > Programs > Administrative Tools > Active Directory Users and Computers.
3. InActive Directory Users and Computers, create a new service account with the following attributes:
« Name: BESAdmin
« User location: Create a Microsoft Exchange mailbox

e Group membership: Domain user


http://support.novell.com/cgi-bin/search/searchtid.cgi?2974002.htm
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Set Send As permission to enable BlackBerry users to send messages
Visit www.support.microsoft.com/kb/907434/en-us for more information about the Send As permission.

1. Onthe taskbar, click Start > Administrative Tools > Active Directory Users and Computers.
2. On the View menu, click Advanced Features.

3. Right-click the root of the domain.

4. Click Properties.

5. On the Security tab, click Advanced.

6. Click Add.

7. Type BESAdmin.

8. Click Check Name.

9. Click OK.

10. Inthe Apply Onto drop-down list, click User Objects.
1. In the Allow column, select the Send As check box.
12. Click Apply.

13. Click OK.

Set Local Security Policy permissions for the service account

Enable the BESAdmin administrator to log in to the local computer, and run the BlackBerry Enterprise Server as a

Microsoft Windows service.

1. Onthe taskbar, click Start > Administrative Tools > Local Security Policy (Domain Controller Security
Policy if your computer is a domain controller).

In the Local Security Settings window, browse to Local Policies > User Rights Assignment.
In the right pane, double-click one of the following options:

* Log on Locally (Windows Server 2000)

e Allow Log on Locally (Windows Server 2003)

Click Add User or Group.

Add the BESAdmin service account to the list.

Click OK.

In the Local Security Settings window, double-click Log On As a Service.
Click Add User or Group.

. Add the BESAdmin service account to the list.

10. Click OK.

© o N o v s
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Set Local Administrator permission for the service account
Enable the BESAdmin administrator to manage the domain.

Set Local Administrator permission on a domain controller
Perform this task if you computer is a domain controller.

o A w N~

On the taskbar, click Start > Administrative Tools > Active Directory Users and Computers.
Select the Builtin folder.

In the right pane, double-click Administrators.

On the Members tab, click Add.

In the Select Users, Contacts, Computers, or Groups window, select the BESAdmin service account.
Click OK.

Set Local Administrator permission on a member server
Perform this task if your computer is a member server.

o v A W N~

Click Start > Administrative Tools > Computer Management.

In the left pane, expand System Tools and click Local Users and Groups.

In the right pane, double-click Groups.

Right-click Administrators and click Properties.

In the Select Users, Contacts, Computers, or Groups window, select the BESAdmin service account.
Click OK.

Set Exchange View Only Administrator permission for the service account
Enable the BESAdmin administrator to manage users and groups.
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On the taskbar, click Start > Programs > Microsoft Exchange > System Manager.
Expand Administrative Groups.

Right-click First Administrative Group.

Click Delegate Control.

In the Exchange Administration Delegation Wizard, click Next.

Click Add.

Click Browse.

Click the BESAdmin service account.

Click OK.

In the Delegate Control window, in the Role drop-down list, click Exchange View Only Administrator.
Click OK to add the BESAdmin service account to the Users and Groups list.
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12. Click Next.
13. Click Finish.

Set Microsoft Exchange Server permissions for the service account
Enable the BlackBerry Enterprise Server to write information to the service account mailbox.

On the taskbar, click Start > Programs > Microsoft Exchange > System Manager.
Browse to Administrative Groups > First Administrative Group > Servers.
Right-click the Microsoft Exchange computer name.

Click Properties.

On the Security tab, click the BESAdmin service account.

o v A wN

In the Allow column, select the following check boxes:

e Administer Information Store

* SendAs

* Receive As

Select Allow inheritable permissions from parent to propagate to this object.
Click OK.

Click OK again.
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Installing the BlackBerry Enterprise Server

Installing the BlackBerry Enterprise Server

Installing the BlackBerry Enterprise Server

Before installing the BlackBerry Enterprise Server, make sure that you have the following installation credentials:
< client access license key

e SRPidentifier

e SRPkey

*  SRP host (if provided by your vendor)

Make sure that you have the following information from your environment:

¢ name of the mailbox that you created for the BESAdmin service account

= computer name of your messaging server

« computer name and port number of the proxy server (if applicable)

Install the BlackBerry Enterprise Server

1. Log in to your computer using the BESAdmin service account that you created.

2. Unzip the set up program file contents to <drive>\Research In Motion\BlackBerry Enterprise Server 4.1.x.

3. Double-click the setup.exe file.

4. Complete the license agreement screen.

5. On the Setup Type screen, click BlackBerry Enterprise Server.

6. Complete the next three screens.

7. Onthe MSDE Option screen, click Yes, install MSDE 2000 locally.

8. Complete the next two screens.

9. When prompted to restart the computer, click Yes.

10. Log in to your computer using your BESAdmin service account, and wait for the setup program to start
automatically.

11.  On the Database screen, perform the following actions:

* Inthe Database Location field, click Local.

e Click Windows authentication.
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12.
13.
14.
15.

16.

17.

When you are prompted to create the BESMgmt database, click Yes.

Complete the License Key screen.

On the SRP Address screen, leave the host as the default and click Test Network Connection.
On the SRP Settings screen, perform the following actions:

< Type the SRP identifier and SRP authentication key.

» Type the host routing information if your vendor provides it.

e Click Validate SRP Key and ID to confirm that the information is correct.

In the Microsoft Exchange Server window, perform the following actions:

» Inthe Microsoft Exchange server field, type your messaging server name.

« Inthe Mailbox field, type the name of the mailbox that you created for your service account.
e Click Check Name to verify the information.

» Inthe confirmation dialog box, click Apply.

Complete the installation wizard.
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Setting up a BlackBerry device

Setting up a BlackBerry device

To set up a BlackBerry device on the BlackBerry Enterprise Server, you add a user account to the BlackBerry
Enterprise Server and then send the user account a wireless enterprise activation password. The user receives the
wireless enterprise activation password in an email message, and then types that password on the BlackBerry
device to associate the user account with that BlackBerry device.

Add a user account to the BlackBerry Enterprise Server

In the BlackBerry Manager, in the left pane, click a BlackBerry Enterprise Server.
On the Server Configuration tab, click Common.

Click Add Users.

In the Show Names from the drop-down list, click an address group.

In the user list, click a user.

Click Select.

Click OK.
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Send a wireless enterprise activation password to a user
By default, wireless enterprise activation passwords expire after 48 hours.

1. Inthe BlackBerry Manager, in the left pane, click a BlackBerry Enterprise Server.
On the Users tab, click the user account.

In the bottom pane, click Service Access.

Click Generate and Email Activation Password.

Click OK.

ooa WwoN

Activate a BlackBerry device over the wireless network

To activate a BlackBerry device over the wireless network, the user must be in a wireless coverage area and the
radio on the BlackBerry device must be turned on.

1. Inthe device options, click Advanced Options.
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Click Enterprise Activation.

Type the corporate email address and the password.
Click the trackwheel.

Click Activate.

oos WwoN



Appendix A: Troubleshooting

Determine if a Microsoft Exchange System Manager upgrade is required
Troubleshooting the installation process

Determine if a Microsoft Exchange System Manager upgrade
is required

1. Onthe BlackBerry Enterprise Server, in Windows Explorer, search for the MAPI32.dIl and CDO.dII files. You
might see copies of the files in the C:\<Windows Directory>\System32 or C:\Program Files\exchsrvr\bin
directories, and only one copy of CDO.dII.

Record the version numbers of each file.
On the Microsoft Exchange Server, repeat steps 1and 2.

If the BlackBerry Enterprise Server does not have equal or later versions of MAPI32.dIl and CDO.dIl than the
Microsoft Exchange server, upgrade the Microsoft Exchange System Manager.

Troubleshooting the installation process

The setup program does not install a third-party tool successfully

1. Inthe BlackBerry Enterprise Server installation media, open the Tools folder and locate the application that
you want to install.

Install the third-party tool manually.

Start the setup program again.

The “Previous version detected but no database available” message appears
Verify that the registry keys identifying your BlackBerry Configuration Database are present.

1. Onthe computer where you plan to install the BlackBerry Enterprise Server, start the Registry Editor.

2. Inthe left pane, browse to HKEY_LOCAL_MACHINE/Software/Research In Motion/BlackBerry Enterprise
Server/Database.

3. Create the following string values (if they do not exist):
Note: These values are case-sensitive.

« DatabaseName: Type the name of the BlackBerry Configuration Database.
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« DatabaseServerMachineName: Type the computer name of the database server.

4. Start the setup program again.

The client access license key does not write to the database

1. Cancel the setup program.

2. Log out from the computer.

3. Log into the computer using the same account that you used to start the installation process.
4

Start the setup program again.

The setup program does not prompt you to edit or confirm the MAPI profile
during the installation
Create and edit the MAPI profile manually.

1. Inthe BlackBerry Enterprise Server installation media, in the Tools folder, double-click the Fixmapisvc.exe
file.

At C:\winnt\system32\ or C:\windows\system32\, verify that the mapisvc.inf file is installed.
On the taskbar, click Start > BlackBerry Enterprise Server > Edit MAPI Profile.

Type the Microsoft Exchange Server name.

Click the mailbox associated with the MAPI profile.

Click OK.

o U A WwN

The setup program needs access to the original media for Microsoft .NET
Framework Version 1.1

This issue might occur if you install service pack 1to a previously installed version of Microsoft .NET Framework
Version 1.1.

1. When the setup program prompts you for the location of the netfx.msi file, in the BlackBerry Enterprise Server
installation media, browse to the Tools folder.

2. Open the netfx.msi file.






*2:BlackBerry.

©2006 Research In Motion Limited
Published in Canada.



	Preparing for the installation
	Overview
	Related resources
	Planning your installation
	System requirements
	Operating system
	Hardware
	Messaging server
	Network
	Database

	Setting up a Microsoft Windows service account and mailbox
	Create a Microsoft Windows service account and mailbox
	Set Send As permission to enable BlackBerry users to send messages
	Set Local Security Policy permissions for the service account
	Set Local Administrator permission for the service account
	Set Exchange View Only Administrator permission for the service account
	Set Microsoft Exchange Server permissions for the service account


	Installing the BlackBerry Enterprise Server
	Installing the BlackBerry Enterprise Server
	Install the BlackBerry Enterprise Server


	Setting up a BlackBerry device
	Setting up a BlackBerry device
	Add a user account to the BlackBerry Enterprise Server
	Send a wireless enterprise activation password to a user
	Activate a BlackBerry device over the wireless network


	Appendix A: Troubleshooting
	Determine if a Microsoft Exchange System Manager upgrade is required
	Troubleshooting the installation process
	The setup program does not install a third-party tool successfully
	The “Previous version detected but no database available” message appears
	The client access license key does not write to the database
	The setup program does not prompt you to edit or confirm the MAPI profile during the installation
	The setup program needs access to the original media for Microsoft .NET Framework Version 1.1




<<
  /ASCII85EncodePages false
  /AllowTransparency false
  /AutoPositionEPSFiles true
  /AutoRotatePages /None
  /Binding /Left
  /CalGrayProfile (Dot Gain 20%)
  /CalRGBProfile (sRGB IEC61966-2.1)
  /CalCMYKProfile (U.S. Web Coated \050SWOP\051 v2)
  /sRGBProfile (sRGB IEC61966-2.1)
  /CannotEmbedFontPolicy /OK
  /CompatibilityLevel 1.3
  /CompressObjects /Tags
  /CompressPages true
  /ConvertImagesToIndexed true
  /PassThroughJPEGImages true
  /CreateJDFFile false
  /CreateJobTicket false
  /DefaultRenderingIntent /Default
  /DetectBlends true
  /ColorConversionStrategy /LeaveColorUnchanged
  /DoThumbnails false
  /EmbedAllFonts true
  /EmbedJobOptions true
  /DSCReportingLevel 0
  /SyntheticBoldness 1.00
  /EmitDSCWarnings false
  /EndPage -1
  /ImageMemory 1048576
  /LockDistillerParams false
  /MaxSubsetPct 100
  /Optimize true
  /OPM 1
  /ParseDSCComments true
  /ParseDSCCommentsForDocInfo true
  /PreserveCopyPage true
  /PreserveEPSInfo true
  /PreserveHalftoneInfo false
  /PreserveOPIComments false
  /PreserveOverprintSettings true
  /StartPage 1
  /SubsetFonts false
  /TransferFunctionInfo /Apply
  /UCRandBGInfo /Preserve
  /UsePrologue false
  /ColorSettingsFile ()
  /AlwaysEmbed [ true
  ]
  /NeverEmbed [ true
  ]
  /AntiAliasColorImages false
  /DownsampleColorImages true
  /ColorImageDownsampleType /Bicubic
  /ColorImageResolution 300
  /ColorImageDepth -1
  /ColorImageDownsampleThreshold 1.50000
  /EncodeColorImages false
  /ColorImageFilter /DCTEncode
  /AutoFilterColorImages true
  /ColorImageAutoFilterStrategy /JPEG
  /ColorACSImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /ColorImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /JPEG2000ColorACSImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /JPEG2000ColorImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /AntiAliasGrayImages false
  /DownsampleGrayImages true
  /GrayImageDownsampleType /Bicubic
  /GrayImageResolution 300
  /GrayImageDepth -1
  /GrayImageDownsampleThreshold 1.50000
  /EncodeGrayImages false
  /GrayImageFilter /DCTEncode
  /AutoFilterGrayImages true
  /GrayImageAutoFilterStrategy /JPEG
  /GrayACSImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /GrayImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /JPEG2000GrayACSImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /JPEG2000GrayImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /AntiAliasMonoImages false
  /DownsampleMonoImages true
  /MonoImageDownsampleType /Bicubic
  /MonoImageResolution 1200
  /MonoImageDepth -1
  /MonoImageDownsampleThreshold 1.50000
  /EncodeMonoImages false
  /MonoImageFilter /CCITTFaxEncode
  /MonoImageDict <<
    /K -1
  >>
  /AllowPSXObjects false
  /PDFX1aCheck false
  /PDFX3Check false
  /PDFXCompliantPDFOnly false
  /PDFXNoTrimBoxError true
  /PDFXTrimBoxToMediaBoxOffset [
    0.00000
    0.00000
    0.00000
    0.00000
  ]
  /PDFXSetBleedBoxToMediaBox true
  /PDFXBleedBoxToTrimBoxOffset [
    0.00000
    0.00000
    0.00000
    0.00000
  ]
  /PDFXOutputIntentProfile ()
  /PDFXOutputCondition ()
  /PDFXRegistryName (http://www.color.org)
  /PDFXTrapped /Unknown

  /Description <<
    /JPN <FEFF3053306e8a2d5b9a306f30019ad889e350cf5ea6753b50cf3092542b308030d730ea30d730ec30b9537052377528306e00200050004400460020658766f830924f5c62103059308b3068304d306b4f7f75283057307e305930023053306e8a2d5b9a30674f5c62103057305f00200050004400460020658766f8306f0020004100630072006f0062006100740020304a30883073002000520065006100640065007200200035002e003000204ee5964d30678868793a3067304d307e305930023053306e8a2d5b9a306b306f30d530a930f330c8306e57cb30818fbc307f304c5fc59808306730593002>
    /FRA <>
    /DEU <>
    /PTB <>
    /DAN <>
    /NLD <>
    /ESP <>
    /SUO <>
    /ITA <>
    /NOR <>
    /SVE <>
    /ENU <FEFF005500730065002000740068006500730065002000730065007400740069006e0067007300200074006f0020006300720065006100740065002000500044004600200064006f00630075006d0065006e00740073002e>
  >>
>> setdistillerparams
<<
  /HWResolution [2400 2400]
  /PageSize [612.000 792.000]
>> setpagedevice


