DST Patch Loader

Check again for devices

Please check the following items:

  1. This page requires Internet Explorer v5.5 or later, running on Windows 2000 SP4 or later.
  2. An ActiveX control provided by Research In Motion Ltd. needs to be installed to update your BlackBerry device. Click on the Internet Explorer Information Bar, shown at the top of the page, and select "Install ActiveX Control..." to install this component.
  3. If you are using Windows Vista, you may need to install the DST 2007 Update Loader control manually, by downloading and installing the control packaged with Windows Installer. This installer is available here.