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No se pueden escribir o actualizar los datos de aplicación

ID de documento: KB00729
Última modificación: 9/7/2007 1
Tipo de documento: Support

Entorno

  • BlackBerry® Desktop Software 2.1 a 4.2
  • BlackBerry® Device Software 4.2
  • IBM® Lotus Notes®
  • Microsoft® Outlook®
  • Microsoft Outlook Express
  • Microsoft® Windows® 2000 y XP
  • Sage Software ACT!®



Problema

Al sincronizar los datos del organizador (como los contactos, las entradas del calendario, las tareas y las notas) entre el smartphone BlackBerry y el ordenador, se muestra el mensaje de error siguiente:

No se pueden escribir o actualizar los datos de aplicación.




Causa

Resumen de causas

Este problema puede deberse a uno de los motivos siguientes:

  1. Un contacto incluido en Microsoft Outlook, Sage Software ACT!, IBM Lotus Notes o IBM® Lotus Organizer® no tiene información en uno o varios campos.
  2. El smartphone BlackBerry no cuenta con suficiente memoria para sincronizar los datos del organizador.
  3. La base de datos del organizador del usuario del smartphone BlackBerry contiene información no válida.
  4. Una base de datos de aplicación del smartphone BlackBerry está dañada.
  5. La base de datos de la libreta de direcciones de IBM Lotus Notes tiene una plantilla personalizada incompatible con BlackBerry® Desktop Manager.
  6. La libreta de direcciones del smartphone BlackBerry está dañada.
  7. El smartphone BlackBerry falla al sincronizarse con alguna aplicación del organizador, entre ellas, el calendario, la lista de notas o de tareas debido a que la base de datos está dañada temporalmente.
  8. La libreta de direcciones del smartphone BlackBerry contiene un contacto en blanco.



Resolución

A continuación figuran posibles soluciones para este problema.

Nota: un primer remedio eficaz cuando se produzca este error es realizar un restablecimiento manual en el smartphone BlackBerry. Para obtener más información, consulte el artículo KB02141.

Causa 1

Un contacto incluido en Microsoft Outlook, Sage Software ACT!, IBM Lotus Notes o IBM Lotus Organizer no contiene información en ninguno de los siguientes campos:

  • Nombre
  • Apellido
  • Nombre de la empresa

Resolución

BlackBerry Desktop Software 4.2 Service Pack 1 (4.2.1) o posterior reconocerá los registros que no tengan información en los campos Nombre, Apellido y Nombre de la empresa. Actualice a BlackBerry Desktop Software 4.2.1 para completar la sincronización. Revise los contactos incluidos en Microsoft Outlook, Sage Software ACT!, IBM Lotus Notes o IBM Lotus Organizer para agregar datos a los campos Nombre, Apellido o Nombre de la empresa. De esta forma se asegurará que se incluyen en futuras sincronizaciones. Para obtener más información sobre este problema, consulte el artículo KB11366.


Causa 2

El smartphone BlackBerry no dispone de memoria libre suficiente para sincronizar los datos del organizador con el equipo.

Resolución

Para aumentar la cantidad de memoria disponible en el smartphone BlackBerry, complete los siguientes pasos.

Nota: realice una copia de seguridad de los datos del smartphone BlackBerry con la herramienta Copia de seguridad/restauración de archivos en BlackBerry Desktop Manager antes de continuar. Para obtener más información, consulte el artículo KB11625.

Use BlackBerry Desktop Manager para reducir el intervalo de días en el calendario.

Al reducir el intervalo de días del calendario, se limita el número de citas o eventos para reconciliar con el smartphone BlackBerry. Se pueden reconciliar los siguientes elementos:

  • Todos los elementos
  • Sólo elementos futuros
  • Elementos incluidos en un intervalo de días

Al reducir el intervalo de días, se creará más espacio de almacenamiento disponible en el smartphone BlackBerry. Para obtener más información, consulte el artículo KB05347.

Use Application Loader para eliminar las aplicaciones no deseadas del smartphone BlackBerry

Para obtener más información, consulte el artículo KB10376.


Causa 3

La base de datos del organizador del usuario del smartphone BlackBerry (como, por ejemplo, Microsoft Outlook, Sage Software ACT!, IBM Lotus Notes o IBM Lotus Organizer) contiene información no válida.

Nota: antes de continuar, confirme que la entrada del contacto no está afectada por el problema que se ha descrito en la Causa 1.

Resolución

Active el registro avanzado para identificar el registro que contiene la información no válida y bórrela.

  1. Active el registro avanzado. Para obtener más información, consulte el artículo KB01451.
  2. Cuando haya identificado el registro con la información no válida, localice y borre la entrada en el equipo.

Causa 4

Una base de datos de la aplicación (libreta de direcciones, calendario, bloc de notas o tareas) del smartphone BlackBerry está dañada.

Resolución

Borre la base de datos dañada.

  1. Determine qué base de datos está dañada. Para obtener más información, consulte el artículo KB03069.
  2. Haga una copia de seguridad de la base de datos dañada. Para obtener más información, consulte el artículo KB11297.
  3. Borre la base de datos dañada.
    1. Abra la herramienta Copia de seguridad/restauración de archivos y haga clic en Avanzada.
    2. Seleccione las bases de datos dañadas y haga clic en Borrar.
  4. Sincronice el smartphone BlackBerry.

Causa 5

La base de datos de la libreta de direcciones de IBM Lotus Notes tiene una plantilla personalizada incompatible con BlackBerry Desktop Manager.

Resolución

Aplique la plantilla estándar a la libreta de direcciones IBM Lotus Notes del usuario del smartphone BlackBerry.

Nota: una vez de haya aplicado la plantilla estándar, confirme que el usuario del smartphone BlackBerry puede sincronizar los contactos. Este problema debe remitirse al departamento de TI del usuario del smartphone BlackBerry porque puede darse el mismo problema en otros smartphones BlackBerry si una plantilla personalizada se está usando mucho en el entorno.


Causa 6

La libreta de direcciones del smartphone BlackBerry está dañada.

Síntomas

  1. Consulte el artículo KB04317 si el mensaje de error de la libreta de direcciones es el siguiente:

    dirección actualizada externamente. Se perderán los cambios y se cerrará el visor.

  2. Tif.log indica una entrada de contacto dañada en Microsoft Outlook. Después de eliminar el contacto de Microsoft Outlook y sincronizar de nuevo el smartphone BlackBerry, el contacto seguirá en el smartphone BlackBerry.
  3. La creación de un contacto nuevo en el smartphone BlackBerry generará el siguiente mensaje de error:

Excepción no detectada Java.lang. Excepción de puntero nulo

Resolución

  1. Realice una copia de seguridad del smartphone BlackBerry antes de sincronizar. Para obtener más información, consulte el artículo KB11625.
  2. Borre la base de datos de la libreta de direcciones.
    1. Abra la herramienta Copia de seguridad/restauración de archivos y haga clic en Avanzada.
    2. Seleccione la base de datos Libreta de direcciones y haga clic en Borrar.
  3. Efectúe un restablecimiento manual del smartphone BlackBerry. Para obtener más información, consulte el artículo KB02141.
  4. Sincronice el smartphone BlackBerry con Microsoft Outlook. Consulte el artículo KB05313, tarea 3, segunda opción. 


Causa 7

El smartphone BlackBerry falla al sincronizarse con alguna aplicación del organizador, entre ellas, el calendario, la lista de notas o de tareas debido a que la base de datos está dañada temporalmente.

Síntomas

Al crear una entrada nueva en una aplicación del organizador se generará un error y la entrada no se creará en el smartphone BlackBerry.

Resolución

Realice un restablecimiento manual en el smartphone BlackBerry. Para obtener información al respecto, consulte el artículo KB02141.


Causa 8

La libreta de direcciones del smartphone BlackBerry contiene un contacto en blanco.

Resolución

Si la lista está ordenada alfabéticamente, compruebe la parte superior de la lista de nombres de la libreta de direcciones para ver si en alguno aparece <Sin nombre>.
Elimine las entradas en las que figure <Sin nombre> en el campo del nombre.




Información adicional

Si los procedimientos anteriores no resuelven el problema, borre y restablezca los datos y las aplicaciones en el smartphone BlackBerry.

Para eliminar los datos y las aplicaciones del smartphone BlackBerry, realice los siguientes pasos:

  1. Realice una copia de seguridad de los datos del smartphone BlackBerry usando la función de copia de seguridad y restauración de archivos. Para obtener más información, consulte el artículo KB11625.
  2. Borre todos los datos y las aplicaciones del smartphone BlackBerry. Para obtener más información, consulte el artículo KB02318.

Para restaurar las aplicaciones del smartphone BlackBerry, lleve a cabo el siguiente paso:

  1. Reinstale BlackBerry Device Software usando Application Loader. Para obtener más información, consulte el artículo KB11320.

Para restaurar los datos del smartphone BlackBerry, lleve a cabo los siguientes pasos:

  1. En BlackBerry Desktop Manager, haga doble clic en el icono Copia de seguridad/restauración de archivos.
  2. Haga clic en Restauración de archivos y seleccione el archivo de copia de seguridad que creó antes de borrar los datos en el smartphone BlackBerry.
  3. Haga clic en Abrir. Los datos del smartphone BlackBerry se restablecerán.


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