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No se pueden enviar mensajes porque se ha revocado el permiso Enviar como

ID de documento: KB04707
Última modificación: 11/5/2007
Tipo de documento: Support

Entorno

  • BlackBerry® Enterprise Server Software versiones 2.1 y de la 3.6 hasta la 4.1 para Microsoft® Exchange 
  • Microsoft® Exchange Server 2003 Service Packs 1 y 2
  • Microsoft® Exchange Server 2000 Service Pack 3
  • SDR75493
  • SDR82260

Introducción

Este artículo se aplica a Microsoft Exchange Server 2003 y 2000, dentro de los entornos siguientes:

  • Microsoft Exchange Server 2003 Service Pack 1 con la compilación 7233.28 o posterior
  • Microsoft Exchange Server 2003 Service Pack 2 con la compilación 7650.23 o posterior
  • Microsoft Exchange Server 2000 Service Pack 3 con la compilación 6619.4 o posterior

Importante: si aplica la revisión que se describe en el artículo 895949 de la base de conocimientos (Microsoft Support Knowledge Base) a Microsoft Exchange Server 2003 Service Pack 1 o Service Pack 2, o si aplica la revisión de Microsoft Exchange Server 2000 Service Pack 3, consulte el artículo KB12827.




Problema

Cuando el usuario de un smartphone BlackBerry trata de enviar un mensaje, se muestra una X roja al lado del mensaje en la lista de mensajes para señalar que no se puede enviar. El campo Estado del mensaje muestra uno de los errores siguientes:

  • El error del mensaje no aparece listado
  • El programa de correo electrónico del escritorio no puede enviar el mensaje.

Nota: el campo Estado del mensaje se muestra encima del campo A dentro del mensaje.

El registro de depuración de BlackBerry Enterprise Server muestra los datos siguientes:

BlackBerry Enterprise Server software versiones 4.0 y 4.1

[40700] (12/13 15:38:10):{0xFF0} {<nombre_usuario>@<dominio>} Receiving packet from device, size=111, TransactionId=-2099843783, Tag=147, content type=CMIME, cmd=0x3
[30112] (12/13 15:38:10):{0xFF0} {<nombre_usuario>@<dominio>} Receiving message from device, RefId=1607656887, Tag=147, TransactionId=-2099843783
[20265] (12/13 15:38:10):{0xFF0} {<nombre_usuario>@<dominio>} MAPIMailbox::Send(ppMAPIMessage) - SubmitMessage (0x80070005) failed
[20265] (12/13 15:38:10):{0xFF0} {<nombre_usuario>@<dominio>} MAPIMailbox::Send(ppMAPIMessage) - SubmitMessage (0x80070005) failed
[20000] (12/13 15:38:10):{0xFF0} {<nombre_usuario>@<dominio>} Send() failed: SUCCESS, Tag=147
[40277] (12/13 15:38:10):{0xFF0} {<nombre_usuario>@<dominio>} Sending message error to device for message 1607656887
[40583] (12/13 15:38:10):{0xFF0} {<nombre_usuario>@<dominio>} Sending packet to device, Size=46, Tag=222, TransactionId=-1012978472

BlackBerry Enterprise Server versión 3.6 y anterior

[40700] (12/13 15:38:10):{0x7FC} {<nombre_usuario>@<dominio>} Receiving packet from device, size=161, TransactionId=-1966367802, Tag=-1091853399, content type=CMIME, cmd=0x3
[30112] (12/13 15:38:10):{0x7FC} {<nombre_usuario>@<dominio>} Receiving message from device, RefId=1473556709, Tag=-1091853399, TransactionId=-1966367802
[20265] (12/13 15:38:10):{0x7FC} {<nombre_usuario>@<dominio>} *** MAPI *** MAPIMailbox::Send(ppMAPIMessage) - SubmitMessage (0x80070005) failed.
[20000] (12/13 15:38:10):{0x7FC} {<nombre_usuario>@<dominio>} Send() failed: ERR_SUBMIT_MAIL, Tag=-1091853399
[40277] (12/13 15:38:10):{0x7FC} {<nombre_usuario>@<dominio>} Sending message error to device for message 1473556709
[40583] (12/13 15:38:10):{0x7FC} {<nombre_usuario>@<dominio>} Sending message to device, Size=85, Tag=6420, TransactionId=-1001413813




Causa

Cuando se aplica la revisión que se describe en el artículo 895949 de la base de conocimientos (Knowledge Base) del sitio Web de asistencia de Microsoft para Microsoft Exchange Server 2003 Service Pack 1 o Service Pack 2, o si se aplica la revisión de Microsoft Exchange Server 2000 Service Pack 3, la utilidad store.exe revoca el permiso Enviar como en todas las cuentas de administración de Microsoft Exchange Server que cuentan con un permiso Administrar almacén de información en el nivel de almacenamiento del buzón de correo.

Nota: para obtener causas y resoluciones adicionales relacionadas con este problema, consulte el artículo KB00274.




Resolución

En función de si se ha aplicado la revisión de Microsoft, aplique la resolución correspondiente de entre las que se indican a continuación.


Solución 1

Si no ha aplicado la revisión de Microsoft, compruebe los requisitos del permiso. Para obtener información acerca de cómo resolver los requisitos del permiso, acceda al artículo 912918 de la base de conocimientos (Knowledge Base) del sitio Web de asistencia de Microsoft.

Nota: no es necesario reiniciar ninguno de los servicios BlackBerry.


Solución 2

Si ha aplicado la revisión de Microsoft, siga los pasos que se indican a continuación, en función de la versión del software BlackBerry Enterprise Server que corresponda.

BlackBerry Enterprise Server versiones 4.0 a 4.1

  1. Compruebe los requisitos del permiso. Para obtener información acerca de cómo resolver los requisitos del permiso, acceda al artículo 912918 de la base de conocimientos (Knowledge Base) del sitio Web de asistencia de Microsoft.
  2. Para borrar la caché de permisos de Microsoft Exchange Server para la cuenta de administración de BlackBerry Enterprise Server, complete los siguientes pasos:
    • Apague el smartphone BlackBerry durante dos horas. 

O

Detenga y reinicie el enrutador BlackBerry.

Importante: al reiniciar ciertos servicios de BlackBerry Enterprise Server, se demorará la entrega de mensajes de correo electrónico en los smartphones BlackBerry. Para obtener más información, consulte el artículo KB04789.

Para detener e iniciar el enrutador BlackBerry Router, complete los siguientes pasos:

  1. En el panel de control de Microsoft Windows®, abra Herramientas administrativas > Servicios.
  2. Haga clic con el botón secundario en BlackBerry Router, haga clic en Detener y espere durante dos horas. 
  3. Haga clic con el botón secundario del ratón en BlackBerry Router y, a continuación, en Iniciar.

Nota: el tiempo predeterminado de almacenamiento de la memoria caché de permisos se controla mediante la entrada del registro Mailbox Cache Age Limit. Por ello, el tiempo que se necesita para borrar la memoria caché de permisos dependerá del valor que se haya definido en esta entrada de registro. Dos horas es la configuración predeterminada para todos los servidores de Microsoft Exchange. Microsoft recomienda que se cambie el tiempo predeterminado de dos horas (120 minutos) a 20 minutos para borrar la memoria caché de permisos. El valor de la entrada del registro Mailbox Cache Age Limit puede cambiar según el entorno. Consulte este valor para determinar el tiempo que los permisos se mantendrán guardados en la memoria caché para la cuenta de administración. Asegúrese de esperar el tiempo definido en la entrada del registro Mailbox Cache Age Limit para que se pueda borrar la memoria caché de permisos. Para obtener otras opciones, acceda al artículo 912918 de la base de conocimientos (Knowledge Base) del sitio Web de asistencia de Microsoft.

Para obtener más información acerca de la entrada del registro Mailbox Cache Age Limit, acceda al artículo 327378 de la base de conocimientos (Knowledge Base) del sitio Web de asistencia de Microsoft o busque la entrada del registro Mailbox Cache Age Limit en el sitio Web de TechNet de Microsoft.

BlackBerry Enterprise Server versión 3.6

  1. Compruebe los requisitos del permiso. Para obtener información acerca de cómo resolver los requisitos del permiso, acceda al artículo 912918 de la base de conocimientos (Knowledge Base) del sitio Web de asistencia de Microsoft.
  2. Para borrar la memoria caché de permisos de Microsoft Exchange Server para la cuenta de administración de BlackBerry Enterprise Server, en el panel de control, abra Herramientas administrativas > Servicios.
  3. Haga clic con el botón secundario del ratón en cada servicio BlackBerry y, a continuación, haga clic en Detener para cada uno.
  4. Espere 20 minutos.
  5. Haga clic con el botón secundario del ratón en cada servicio BlackBerry y, a continuación, haga clic en Iniciar para cada uno.

Nota: el tiempo predeterminado de almacenamiento de la memoria caché de permisos se controla mediante la entrada del registro Mailbox Cache Age Limit. Por ello, el tiempo que se necesita para borrar la memoria caché de permisos dependerá del valor que se haya definido en esta entrada de registro. Dos horas es el tiempo predeterminado para los servidores de Microsoft Exchange. Microsoft recomienda que se cambie el tiempo predeterminado de dos horas (120 minutos) a 20 minutos para borrar la memoria caché de permisos. El valor de la entrada del registro Mailbox Cache Age Limit puede cambiar según el entorno. Consulte este valor para determinar el tiempo que los permisos se mantendrán guardados en la memoria caché para la cuenta de administración. Asegúrese de que espera la cantidad de tiempo establecida en la entrada de registro Mailbox Cache Age Limit para permitir que se borre la caché de permisos. Para obtener otras opciones, acceda al artículo 912918 de la base de conocimientos (Knowledge Base) del sitio Web de asistencia de Microsoft.

Para obtener más información acerca de la entrada del registro Mailbox Cache Age Limit, acceda al artículo 327378 de la base de conocimientos (Knowledge Base) del sitio Web de asistencia de Microsoft o busque la entrada del registro Mailbox Cache Age Limit en el sitio Web de TechNet de Microsoft.

Importante: al reiniciar ciertos servicios de BlackBerry Enterprise Server, se demorará la entrega de mensajes en los smartphones BlackBerry. Para obtener más información, consulte el artículo KB04789.

Cuentas protegidas

Si el permiso Enviar como se ha revocado en la cuenta de un usuario de Microsoft® Active Directory® porque el objeto de usuario comparte la pertenencia con una cuenta protegida, siga los pasos siguientes:

Nota: para obtener más información y ver una lista completa de cuentas protegidas, acceda al artículo 907434 de la base de conocimientos (Knowledge Base) del sitio Web de asistencia de Microsoft.

  1. Elimine la pertenencia a la cuenta protegida del objeto de usuario de Microsoft Active Directory.
  2. Asigne de nuevo el permiso Enviar como al objeto de usuario. Para obtener otras opciones, acceda al artículo 912918 de la base de conocimientos (Knowledge Base) del sitio Web de asistencia de Microsoft.
  3. Espere a que se produzca la duplicación de Microsoft Active Directory o fuércela.
  4. Realice una de las acciones siguientes:
    • Elimine el usuario del smartphone BlackBerry de BlackBerry Enterprise Server y espere 20 minutos. Agregue y active de nuevo el usuario del smartphone BlackBerry en BlackBerry Enterprise Server.
    • En función de la versión de software de BlackBerry Enterprise Server, detenga el enrutador BlackBerry o BlackBerry Enterprise Server y espere 20 minutos. Inicie de nuevo BlackBerry Router o BlackBerry Enterprise Server.

      Importante: al reiniciar ciertos servicios de BlackBerry Enterprise Server, se demorará la entrega de mensajes en los smartphones BlackBerry. Para obtener más información, consulte el artículo KB04789.

Sugerencia: para ver el vídeo de formación en línea Cómo comprobar los permisos "Enviar como" de Exchange, haga clic aquí.




Información adicional

Es posible modificar los permisos de Active Directory para permitir a usuarios de smartphones BlackBerry que sean miembros de grupos protegidos enviar mensajes desde sus dispositivos BlackBerry sin crear cuentas de correo electrónico secundarias. Para obtener más información acerca de cómo modificar los permisos que están asociados con el objeto AdminSDHolder de Active Directory y que se han modificado con la última actualización de Microsoft Exchange, acceda al artículo 817433 de la base de conocimientos (Knowledge Base) del sitio Web de asistencia de Microsoft.

Importante: ni Microsoft ni Research In Motion recomiendan este procedimiento.


Revisión de cambios en el horario de verano (DST) 2007 y permiso Enviar como

Con la nueva actualización de los objetos de datos de colaboración (CDO) de Microsoft, cada usuario de smartphone BlackBerry en Active Directory debe contar con el permiso Enviar como activo en la cuenta de administración de BlackBerry Enterprise Server.  Si el permiso Enviar como no está activo en la cuenta de administración, el usuario del smartphone BlackBerry no podrá enviar mensajes desde el smartphone BlackBerry.

Cuando se agrega un usuario de smartphone BlackBerry nuevo a BlackBerry Enterprise Server, los administradores deben comprobar que el permiso Enviar como está activo en la cuenta de administración de BlackBerry Enterprise Server dentro de Active Directory. Cuando se añade un usuario nuevo de smartphone BlackBerry a BlackBerry Enterprise Server, el usuario del smartphone BlackBerry debe heredar el permiso Enviar como de un objeto principal en Active Directory (por ejemplo, a través de permisos de grupo) o BlackBerry Enterprise Server debe activar automáticamente este permiso al usuario del smartphone BlackBerry. Si esto no se produce, use la herramienta SetSendAsPermission para definir el permiso.

Para descargar la herramienta SetSendAsPermission, haga clic aquí. Para obtener más información sobre cómo usar la herramienta SetSendAsPermission, consulte el artículo KB12300.

Para obtener más información acerca de la actualización de Microsoft relativa a los cambios en el DST de 2007 para Microsoft Exchange 2003 Service Pack 2, acceda al artículo 926666 de la base de conocimientos (Knowledge Base) del sitio Web de asistencia de Microsoft.

Para obtener más información sobre la repercusión de los cambios en el DST de 2007 para las soluciones BlackBerry, acceda a www.blackberry.com/dst2007.



Productos y servicios:

  • BlackBerry Enterprise Server para Microsoft Exchange