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Sincronización unilateral inalámbrica del calendario para uno o varios usuarios de dispositivos BlackBerry

ID de documento: KB05270
Última modificación: 7/11/2007
Tipo de documento: Support

Entorno

  • BlackBerry® Enterprise Server Software 2.1 a 4.1
  • BlackBerry® Mobile Data System (BlackBerry MDS)
  • Microsoft® Exchange 5.5, Microsoft Exchange 2000 y Microsoft Exchange 2003
  • Microsoft Windows® 2000
  • Microsoft Windows Server® 2003



Problema

Sincronización inalámbrica del calendario se realiza de forma unilateral únicamente: desde el calendario de Microsoft Outlook® hasta el del dispositivo BlackBerry. El proceso inicial de sincronización inalámbrica del calendario se ha realizado correctamente.




Causa

Este problema puede deberse a uno de los motivos siguientes:

  1. Los servicios de BlackBerry Enterprise Server no se están ejecutando en la cuenta de servicio de BlackBerry Enterprise Server.
  2. La cuenta de servicio de BlackBerry Enterprise Server carece de los permisos necesarios.
  3. El objeto CDO (Objeto de datos de colaboración) no está presente o no se admite en el entorno de Microsoft Exchange.
  4. La cuenta de servicio de BlackBerry Enterprise Server es un administrador de dominio.



Resolución

Adopte la resolución que corresponda a la causa.

Causa 1

Los servicios de BlackBerry Enterprise Server no se están ejecutando en la cuenta de servicio de BlackBerry Enterprise Server.

Resolución

Compruebe que todos los servicios de BlackBerry Enterprise Server se estén ejecutando en la cuenta de servicio pertinente de BlackBerry Enterprise Server.

Nota: varios servicios de BlackBerry Enterprise Server se ejecutan en la cuenta del sistema local (por ejemplo, los servicios de BlackBerry Attachment o BlackBerry MDS - Apache Tomcat™).

Para confirmar que se ha especificado la cuenta correcta, lleve a cabo los siguientes pasos:

  1. En Herramientas administrativas, seleccione Servicios y haga doble clic en el servicio BlackBerry.
  2. En la ficha Iniciar sesión, compruebe que aparezca el nombre correcto de cuenta del servicio de BlackBerry Enterprise Server.
  3. Si aparece un nombre distinto, realice uno de los siguientes pasos:
    • Si el servidor BlackBerry Enterprise Server se instaló utilizando la cuenta de administrador u otra cuenta administrativa, cambie la cuenta de servicio a la de BlackBerry Enterprise Server. Para obtener más información, consulte uno de los siguientes artículos:
      • Para BlackBerry Enterprise Server Software 3.6, consulte el artículo KB04334.
      • Para BlackBerry Enterprise Server Software 4.0 y 4.1, consulte el artículo KB04293.

      O

    • Si el servidor BlackBerry Enterprise Server se instaló usando la cuenta de servicio de BlackBerry Enterprise Server, cambie la cuenta de servicio a la que corresponda a los servicios de BlackBerry Enterprise Server.

Nota: esto ocurre si un Service Pack o una revisión de BlackBerry Enterprise Server no se instalaron usando la cuenta de servicio de BlackBerry Enterprise Server.


Causa 2

La cuenta de servicio de BlackBerry Enterprise Server carece de los permisos necesarios.

Resolución

Para actualizar los buzones de correo de los usuarios de dispositivos BlackBerry, se requieren los permisos necesarios. Modifique los permisos de la cuenta de servicio de BlackBerry Enterprise Server realizando los siguientes pasos:

Microsoft Exchange Server 2000 y Microsoft Exchange Server 2003

  1. En Exchange System Manager, haga clic con el botón secundario en el nombre del grupo administrativo de Exchange y haga clic en Delegar control.
  2. Haga clic en Siguiente y, a continuación, en Agregar para abrir la ventana Delegar control.
  3. Haga clic en Examinar para abrir la ventana Seleccionar los usuarios,equipos o grupos y, a continuación, seleccione la nueva cuenta de servicio.
  4. En la lista desplegable Función, seleccione Administrador con permiso de vista de Exchange y haga clic en Aceptar.
  5. Haga clic en Siguiente y en Finalizar.
  6. Abra Administrador del sistema de Exchange y acceda a Grupos administrativos/Primer grupo administrativo/Servidores.
  7. Haga clic con el botón secundario en el nombre del servidor Microsoft Exchange, elija Propiedades y haga clic en la ficha Seguridad.
  8. Asegúrese de que se ha activado la casilla de verificación Hacer posible que los permisos heredables de un objeto primario se propaguen a este objeto.
  9. Elija un nombre de cuenta de servicio y seleccione las casillas de verificación adecuadas para conceder los permisos Administrar almacén de información, Recibir como y Enviar como.
  10. Compruebe que no se haya seleccionado ningún permiso denegado para la cuenta de servicio.
  11. Haga clic en Aplicar y, a continuación, en Aceptar.
  12. En Herramientas administrativas, seleccione Usuarios y equipos de Active Directory.
  13. Haga clic con el botón secundario en la cuenta de servicio de BlackBerry Enterprise Server y elija Propiedades.
  14. En la ficha Dependencias, compruebe que aparezca en la lista Usuarios de dominio.
  15. Si el servidor BlackBerry Enteprise Server está instalado en un controlador de dominio, asegúrese de que Administradores aparezca en la lista.

Microsoft Exchange Server 5.5

En el administrador de Exchange, active el permiso de administración de cuentas para la nueva cuenta de servicio tanto en el contenedor de sitio como en el de configuración. Para obtener más información, consulte el artículo KB00886. Para obtener más información sobre cómo configurar los permisos, consulte la documentación de Microsoft Exchange Server 5.5.

Importante: asegúrese de que la cuenta de servicio no forme parte de ningún grupo que pueda tener denegados algunos de los permisos requeridos. Para obtener más información, consulte el artículo KB04557.


Causa 3

El objeto CDO (Objeto de datos de colaboración) no está presente o no se admite en el entorno de Microsoft Exchange.

Resolución

Verifique que el archivo CDO.DLL sea compatible con el entorno de Microsoft Exchange.

Para Microsoft Exchange 2000 y Microsoft Exchange 2003

  1. Acceda al directorio Exchsrvr\bin para comprobar la versión del archivo CDO.DLL en el servidor Microsoft Exchange.
  2. Compruebe que el archivo CDO.DLL del servidor BlackBerry Enterprise Server sea de la misma versión (o una posterior) del archivo CDO.DLL ubicado en el servidor Microsoft Exchange.

    Nota: si hay varias versiones del archivo CDO.DLL, compruebe que todas las copias coincidan.

  3. Desde el símbolo del sistema, acceda al directorio en el que se encuentra el archivo CDO.DLL.
  4. Escriba regsvr32 cdo.dll y pulse INTRO. Se mostrará una confirmación que indica que el archivo se ha registrado correctamente.

Para Microsoft Exchange 5.5

  1. Acceda al directorio System32 para comprobar la versión del archivo CDO.DLL en el servidor Microsoft Exchange.
  2. Compruebe que el archivo CDO.DLL del servidor BlackBerry Enterprise Server sea de la misma versión (o una posterior) del archivo CDO.DLL ubicado en el servidor Microsoft Exchange.

    Nota: si hay varias versiones del archivo CDO.DLL, compruebe que todas las copias coincidan.

  3. Desde el símbolo del sistema, acceda al directorio en el que se encuentra el archivo CDO.DLL.
  4. Escriba regsvr32 cdo.dll y pulse INTRO. Se mostrará una confirmación que indica que el archivo se ha registrado correctamente.

Nota: para obtener información sobre cómo obtener y aplicar el archivo CDO.DLL, consulte el artículo KB02937. Para comprobar que el archivo CDO.DLL está registrado, consulte el artículo KB04912.


Causa 4

La cuenta de servicio de BlackBerry Enterprise Server es un administrador de dominio.

Resolución

Compruebe que la cuenta de servicio de BlackBerry Enterprise Server no sea un administrador de dominio.




Información adicional

Si la cuenta de servicio de BlackBerry Enterprise Server forma parte de los administradores de dominio o de los grupos de administradores de Enterprise, los permisos Enviar como se revocarán automáticamente. Sin el permiso Enviar como, el servidor BlackBerry Enterprise Server no podrá actualizar el calendario del usuario del dispositivo BlackBerry en el servidor Microsoft Exchange. Compruebe que la cuenta de servicio no herede esta función de los grupos de Microsoft Active Directory® como, por ejemplo, los administradores de dominio o que no sea miembro de esta función.

El artículo KB02466 proporciona información acerca de la sincronización unilateral del calendario cuando se conecta BlackBerry Enterprise Server Software 3.5.

El artículo KB03784 proporciona información sobre la fuga de memoria de del controlador de dominio de Windows Server 2003 que influye en la sincronización inalámbrica del calendario.

El artículo 821897 de la base de conocimientos (Knowledge Base) del sitio de asistencia de Microsoft proporciona información adicional acerca de cómo asignar acceso de cuenta de servicio a todos los buzones de Microsoft Exchange Server 2003.



Productos y servicios:

  • BlackBerry Enterprise Server para Microsoft Exchange